Dataform failing to load for some users
Incident Report for Dataform
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 12:24 UTC
Investigating
We are currently investigating this issue.
Posted Jan 27, 2020 - 12:05 UTC
This incident affected: Dataform Web.